当前位置:088股票学习网 > 股票资讯 > 通达信成交量指标以及真实成交量量能饱和度指标

通达信成交量指标以及真实成交量量能饱和度指标

  • 股票资讯
  • 2020-10-28 18:32
  • 关键字:通达信成交量指标

通达信成交量目标 通达信实在成交量量能饱满度目标:

N:=34;

预丈量:IF(CURRBARSCOUNT=1 AND PERIOD=5,VOL*240/FROMOPEN,DRAWNULL),COLORCCCCFF,NODRAW;

STICKLINE(CURRBARSCOUNT=1 AND PERIOD=5,预丈量,0,8,-1),COLORYELLOW;

【成交量】:VOL,VOLSTICK,COLORRED;

成交额亿:=AMOUNT/100000000,NODRAW;

流转:=CAPITAL/1000000,NODRAW;

成交流转比:=AMOUNT/CAPITAL/100,NODRAW;

大盘成交【手】:INDEXV,COLORFF55FF,NODRAW;

涨家数:INDEXADV,COLOR0000EE,NODRAW;

跌家数:INDEXDEC,COLOR00EE00,NODRAW;

STICKLINE(CLOSE=REF(CLOSE,1),0,VOL,3.2,0),COLORFF77FF;

STICKLINE(CLOSE》REF(CLOSE,1),0,VOL,2.7,0),COLORFF33FF;

STICKLINE(CLOSE》REF(CLOSE,1),0,VOL,2.1,0),COLORFF55FF;

STICKLINE(CLOSE》REF(CLOSE,1),0,VOL,1,6),COLORFF77FF;

STICKLINE(CLOSE》REF(CLOSE,1),0,VOL,0.8,0),COLORFF99FF;

STICKLINE(CLOSE》REF(CLOSE,1),0,VOL,0.5,0),COLORFFBBFF;

STICKLINE(CLOSE》REF(CLOSE,1),0,VOL,0.1,0),COLORFFDDFF;

STICKLINE(CLOSE《REF(CLOSE,1),0,VOL,3,2),COLORFF1100;

STICKLINE(CLOSE《REF(CLOSE,1),0,VOL,2.7,0),COLORFF3300;

STICKLINE(CLOSE《REF(CLOSE,1),0,VOL,2.1,0),COLORFF5500;

STICKLINE(CLOSE《REF(CLOSE,1),0,VOL,1.6,0),COLORFF7700;

STICKLINE(CLOSE《REF(CLOSE,1),0,VOL,0,8),COLORFF9900;

STICKLINE(CLOSE《REF(CLOSE,1),0,VOL,0.5,0),COLORFFBB00;

STICKLINE(CLOSE《REF(CLOSE,1),0,VOL,0.1,0),COLORFFDD00;

HL10:=WINNER(C/1.1)*V,COLORBLUE;

{STICKLINE(((C/1.1)*V),HL10,0,3,0),COLORMAGENTA;}

STICKLINE(HL10》0,0,HL10,3,2),COLORFF0033;{紫罗兰色--进犯量}

STICKLINE(HL10》0,0,HL10,2.7,0),COLORFF0066;

STICKLINE(HL10》0,0,HL10,2,1),COLORFF0099;

STICKLINE(HL10》0,0,HL10,1.6,0),COLORFF00CC;

STICKLINE(HL10》0,0,HL10,0.5,0),COLORFF00FF;

HL20:=WINNER(C/1.2)*V;

{STICKLINE(((C/1.2)*V),HL20,0,2.1,0)COLORYELLOW;}

STICKLINE(HL20》0,0,HL20,3,2),COLOR0035FF; {黄色--潜入量}

STICKLINE(HL20》0,0,HL20,2.7,0),COLOR0064FF;

STICKLINE(HL20》0,0,HL20,2,1),COLOR0093FF;

STICKLINE(HL20》0,0,HL20,1.6,0),COLOR00C2FF;

STICKLINE(HL20》0,0,HL20,0.5,0),COLOR00FFFF;

HL30:=WINNER(C/1.3)*V;

STICKLINE(((C/1.3)*V),HL30,0,2.5,0),COLORRED;

STICKLINE(HL30》0,0,HL30,3.2,0),COLOR000066;{赤色--拉升量}

STICKLINE(HL30》0,0,HL30,2,7),COLOR000077;

STICKLINE(HL30》0,0,HL30,2.1,0),COLOR000099;

STICKLINE(HL30》0,0,HL30,1.6,0),COLOR0000CC;

STICKLINE(HL30》0,0,HL30,0.2,0),COLORCC66FF;

MA5:MA(V,5),COLORLIMAGENTA;

MA13:MA(V,13),COLORCYAN;

DRAWTEXT(CROSS(MA5,MA13),(V *1.05),‘★’),COLORYELLOW;

{VOL动能均重量}

换手:=V*100/CAPITAL;

主力:=MA(换手,4);

大户:=MA(换手,9);

中户:=MA(换手,17);

散户:=MA(换手,34);

均量:=(主力+大户+中户+散户)/4;

主力能量:=(主力-均量);

大户能量:=(大户-均量);

中户能量:=(中户-均量);

散户能量:=(散户-均量);

DRAWTEXT(V》0 AND ISLASTBAR AND ABS(主力能量),V*0.98,IF(主力能量》0 AND 主力能量》REF(主力能量,1),‘ 组织+’,‘ 组织-’)),COLORYELLOW;

DRAWTEXT(V》0 AND ISLASTBAR AND ABS(大户能量),V/4*3,IF(大户能量》0 AND 大户能量》REF(大户能量,1),‘ 大户+’,‘ 大户-’)),COLOR0000CC;

DRAWTEXT(V》0 AND ISLASTBAR AND ABS(中户能量),V/2,IF(中户能量》0 AND 中户能量》REF(中户能量,1),‘ 中户+’,‘ 中户-’)),COLORMAGENTA;

DRAWTEXT(V》0 AND ISLASTBAR AND ABS(散户能量),V/4,IF(散户能量》0 AND 散户能量》REF(散户能量,1),‘ 散户+’,‘ 散户-’)),COLORCYAN;

N1:=N;

N2:=N1*1.05;

N3:=N1+3;

SAT:=(AMOUNT/C)/(HHV(AMOUNT,20)/HHV(C,20));

量能饱满:IF(SAT》1,1,SAT)*100,COLORYELLOW,NODRAW;

中点:=REFDATE(HHV(V,100)/2,DATE);{量能饱满的变色切换}

STICKLINE(CURRBARSCOUNT=N1,中点*1.9,中点*1.5,100,1),COLOR00DDDD;

STICKLINE(CURRBARSCOUNT=N1,中点*1.88,中点*1.52,量能饱满,0),COLOR0033FF;

STICKLINE(CURRBARSCOUNT=N1,中点*1.82,中点*1.58,量能饱满,0),COLOR0077FF;

STICKLINE(CURRBARSCOUNT=N1,中点*1.76,中点*1.64,

猜你喜欢

广告联系

    474965521